No power when in boost

V
mazda protege5
Hello I have a turbo protege5. It is just a t25 setup with a msp ecu. Turbo is from a Saab and internally gated at 5psi. It has catback exhaust, fmic, greddy bov, boost gauge, and manual boost controller set at 7 psi. The car will build boost pressure quickly and hold but it'll feel like its not really accelerating at all. It seems to be really noticeable especially when I try to accelerate around 3000 rpm. I can hear the turbo spooling loudly and when I let off the throttle the bov goes off really loudly but no power lol. When I try to accelerate harder around 4000 rpm, the car feels more like it is accelerating like it should. I just replaced plugs with gap .028, new wires, and new coils. The hesitating problem is still there but it feels like it's a little better now. No cel. I cleaned maf. Is it the msp tune? The only way to solve this problem is to get engine management?
 
Last edited:

hornsfan10609

Certified Mazda Tech
V
2003.5 Mazdaspeed Protege x2
It's possible, they do hesitate pretty bad on the stock tune. SSAFC is the cheapest and quickest way to make it run better.
 
V
2003.5 Mazdaspeed Protege
Hey, I'm having what sounds like the same problem. If I feather the gas and baby it, it'll accelerate in boost, but if I try to floor it before it gets to boost, it'll just stop accelerating once there's any positive pressure at all. What is SSAFC? I've got a few codes on it right now if that helps at all. IIRC, they were P2009, P0090 and P0660.
 
V
mazda protege5
Ssafc is split second air fuel controller. The issue with mine is that when transitioning into boost it'll run too rich causing the car to hesitate. The ssafc is wired to the ecu and it comes with a map preloaded that leans it out. If you have a afr gauge u can check ur afrs and see if your running rich when wot.
 

hornsfan10609

Certified Mazda Tech
V
2003.5 Mazdaspeed Protege x2
Hey, I'm having what sounds like the same problem. If I feather the gas and baby it, it'll accelerate in boost, but if I try to floor it before it gets to boost, it'll just stop accelerating once there's any positive pressure at all. What is SSAFC? I've got a few codes on it right now if that helps at all. IIRC, they were P2009, P0090 and P0660.
Your codes are from the solenoids on the intake manifold, all three of them most likely have failed. 2009 and 0660 are the ones with the white and green plugs (VICS and VTCS) and 0090 is the FP solenoid (brown plug)
 
V
02P5, 04MSM,97NA
I hate digging up old posts but I am having the same issue..mild throttle and 2-3psi boost it pulls fine (afr starts dropping to 10). Wide open throttle with 7psi it feels like it's fuel starved but the the AFR is at 10

Pretty much the same as zmcmoy had except I only have one code P0090. I have changed the solenoid with some spares I have and no change. Can't believe they are all bad.

Also, when cold the car performs perfect, boost is fine and it pulls like it should. When driving and the temp gauge gets to normal it starts this issue.

I do have a SSAFC that I haven't installed but thought I need to get it running better on it's own first before introducing a new variable.

Only other issue is it's slow to return to idle. I have replaced 90% of the vacuum lines and replaced injector seals. Maybe a dirty idle control valve?

Mostly stock, fmic and hks style bov w/MAF relocated 12-14 inches from throttle body
 
Top