Mazda3 persistent shaking at 60mph...Help!

:
Mazda Protege 5
I have a weird shaking going on at 60 MPH and up. In town it's fine. So far I've replaced tires in five sets, front struts, alignment, front axles. The vibration is still there. I was told by the people that did the struts that my front right ram was bent so I went ahead and replaced that. At first it alleviated the problem but then the shaking came right back just as strong as ever. My current job is as an Uber driver and I have to travel 45 mi each way to get to an area that's busy enough. I'm not sure what else to have checked and I'm tired of telling tire centers that it's not the tires or the wheels. I'm tired of having things balanced and it's not the problem. Any ideas?

Also I forgot to mention after multiple adjustment to the alignment, it still pulls LEFT.
 
Last edited:
:
2010 Mazda 5 Sport
What happens when they put the rear wheels on the front and the fronts on the back?

How many miles on this car?

What year Mazda3? Automatic, Manual? Any accidents with the car?

There must be some play in the system. Tie rod ends seem to come to mind with the alignment issue.
 
Upvote 0
:
2014 Mazda3 S GT auto, 2008 MX5 6-speed
My favorite alignment shop ALWAYS finds the real issue. I suggest you locate one that gets great reviews for such issues and explain exactly what you experience and what has been done thus far.
 
Upvote 0
:
2010 Mazda 5 Sport
My favorite alignment shop ALWAYS finds the real issue. I suggest you locate one that gets great reviews for such issues and explain exactly what you experience and what has been done thus far.
Agreed. Sometimes you have to dig around to find the good repair shops and not the guys just wanting to slap on new tires and send it out.
 
Upvote 0
:
2020 CX-5 AWD
How does that affect the alignment? Isn't that usually a clunk and not a vibration too?

It doesn't, but there's no reason to believe the problem reported by the OP has to be an alignment issue, even though that's what he's been fiddling around with. The problem was stated as: "I have a weird shaking going on at 60 MPH and up", and that could easily be caused by a bad motor mount. I'd always want to consider the well known issues first, before moving on to the less common ones.

It appears that this poster might be one of the many one-and-done type, so there's a good chance we'll never find out what this actual issue is. Might be helpful though to someone else reading this in the future.

And just an FYI that I first hit the 'report' button on your post by mistake, instead of 'reply', as I intended to do. If my action registered a complaint, I certainly had no intent to do that by reporting your post. Perhaps a mod can remove that, if present.

It would be good if the 'report' button could be moved from its current prominent left hand location, and tucked away a bit more on the page.
 
Upvote 0

Antoine

Administrator
Side Note...
It appears that this poster might be one of the many one-and-done type
As a Community we can encourage people to respond and provide updates by using quotes, @ replies and even sending a friendly thread reminder via PM.

And just an FYI that I first hit the 'report' button on your post by mistake, instead of 'reply', as I intended to do. If my action registered a complaint, I certainly had no intent to do that by reporting your post. Perhaps a mod can remove that, if present.

It would be good if the 'report' button could be moved from its current prominent left hand location, and tucked away a bit more on the page.
Thanks for the feedback, to help keep threads on topic, it would be best to use our PM feature in cases like this...As for the Report button, every post has one and for good reason, it’s critical that such functionality is prominent and easily accessible.

Now let’s get back to the topic, thanks.
 
Upvote 0
:
Mazda Protege 5
After replacing struts, axles which didn't need to be replaced, totally new front brakes, I finally got back to the shop to have them recheck the alignment because it was still going to the left and they discovered that one of my tie rods keeps coming loose and I noted that because it I said it had already been tightened twice. That's when they looked and found that my tie rods needed to be replaced so I did that yesterday for $1,100 plus two new back tires.
 
Upvote 0
:
2010 Mazda 5 Sport
Why new tires?

I hope they finally did find the issue. I would not go back to that shop though. I feel they are milking you at this point.

They should have found this earlier. This is their job.
 
Upvote 0
:
Mazda Protege 5
Why new tires?

I hope they finally did find the issue. I would not go back to that shop though. I feel they are milking you at this point.

They should have found this earlier. This is their job.
Back tires were bald and needed to be replaced. Had been to three other shops trying to locate the problem, including about six trips to my local Mazda dealership.
 
Upvote 0
Top