Little confused here.

NRamsey89

Member
:
2003 Mazdaspeed Protege
Alright so after getting my MSP running and everything. I've noticed it been leaking oil, couple drips at first but getting worse as I fixed the no boost problems. First thought it was something on the backside of the block. Oil filter loose? Nope. Previous owner accidentally double up on oil filter gaskets? Changed oil, nope all clear. Wiped everything down as best as I could to "clean status". Took for small spin came home and noticed oil all over again. Then I noticed this. Looks like the turbo oil return line welded (quite shitty too) into the oil pan. The weld is so bad the clamps not on properly, I pulled it back before picture trying to get the hose to fully on. Then realized how bad welding was. So I started shopping around for replacement oil pan. All the ones I found do not have that return fitting. So my question is where is it supposed to actually hook into? How big of a pain and I looking in fixing this properly?

3bdf686fe41afc7ca4d615a4cc3ba3af.jpg



Thanks in advance!
 

NRamsey89

Member
:
2003 Mazdaspeed Protege
That's what I'm thinking of doing hitting up junk yard tomorrow


Sent from my iPhone using Tapatalk Pro
 

hornsfan10609

Certified Mazda Tech
:
2003.5 Mazdaspeed Protege x2
The oil drain goes in the upper oil pan/MBSP, not the lower pan. That is definitely a hack job, to repair it properly you will need an MSP MBSP which you will more than likely not find in a junkyard. They are sold new through street unit or the mazda dealer may be able to get them, or you can find a used one from a partout or someone on the forum that may have one. To install it you will have to remove the engine or trans.