Lewis7789 MS6 GT build thread

:
'86 RX-7 Base, '79 RX-7 GS
I heard that too, Jon. So I ordered one from Mazdaspeed directly. But with 180k miles on my chassis now I'm gradually swapping out just about everything. :)
Yeah, I just ordered another as well. Can't hurt to have a spare, right? Actually, I found a Beck Arnley unit on Amazon for stupid cheap and it seemed silly to pass up the opportunity. Now if only I could find a brake booster the same way...
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
So about two weeks ago I hit steel plate in the road covering some construction that took out my sealed catch can. I also had the dipstick pop out and the last track event so it was time to swap out the catch can, add a PCV plate and a VTA catch can.

Original catch can destroyed. It usually tucks up in the bay but must have been hanging too low.


Damond Motorsports PCV plate. Nice quality.


eBay VTA oil catch can. Nice piece for $60 but the filter it came with would not fit worth a damn. I'm a pretty patience fellow when wrenching and I smashed the s*** out of the original one it came with. I greased it all up, even trimmed the lip down to fit better, no chance. Luckily I stumbled across this K&N unit at Summit Racing when I was picking up a new hose clamp.


The DM sealed can mounted just above the front subframe so I shouldn't have this problem again. Dat homemade bracket doh.


Also painted the IM the fastest/best color of all the colors. The valves looked pretty good too since the EGR is deleted and the catch can was installed by Jake at 138k miles. Also installed the G+ Plus (eBay) silicone radiator hoses I had sitting on the shelf and a coolant flush and oil change.


The car wouldn't start when I got everything back together. Oops, forgot the TB sensor plug. And a ground to the HPFP. Car idled great, no vacuum leaks and ran well but I kept getting a CEL for the knock sensor. Oops, forgot to plug that it. Took her for a test drive and all seems well. :)
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Did my first track event with SCCA Track Night and the event went well. Car performed great and no issues, woo-hoo! Track Nights are only 3 sessions so I tried to make the best of them. The first session was rather slow with a few muscle car conga lines and slower cars not giving point-bys. 2nd session was better. 3rd session I lined up behind a black STi on coincidence. Turned out to be a TON of fun and he's a very good driver and we were about even the whole session. He had 100 hp on me but I had better tires. We chatted after our session, very nice fellow. Fastest lap was the last one before the checkered flag.

I apologize for the crappy video. My GoPro receives a LOT of vibrations through the mount on the roll bar and is nearly unwatchable without the stablization feature enabled on YouTube. I'll be looking into correcting this.

<iframe width="560" height="315" src="https://www.youtube.com/embed/3lJSOPV-pgM" frameborder="0" allowfullscreen></iframe>

I still have a lot to work on as Will was nice enough to give me track notes after reviewing the video. I'll be back in July to work on my times.

It was kinda lonely at the track without track buddies but a made a couple new friends.
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Had another track day with AutoInterests at Mid-Ohio on Monday. The day went great and zero issues with the car the whole day. It was my first session in the advanced class and I was a bit nervous I would be holding up the very fast drivers. But I don't think that was the case and I kept up just fine. Had a great session of cat and mouse with a very nice fellow in an M3. There was some knob out there with a race prepped 370z knobbing around causing a conga line but you'll have that when people get to choose their own class... Otherwise it was a great day. I wasn't able to best my PR of 1:46.6 as my fastest time was a 1:46.8. And I think my Hankooks are finally shot so I'll be switching to the lightly used Star Specs I got soon.

One of the instructors has an SRT10 truck and was out in an advanced session. I thought he was just a crap driver but Marc was riding with him and said he was just messing around trying to drift it.
Longest point-by ever...
<iframe width="560" height="315" src="https://www.youtube.com/embed/9OMUbHskrLI" frameborder="0" allowfullscreen></iframe>
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Removed the factory stereo. The Bose system sucks, I can't hear it over the exhaust and I wear my in-ear-monitors while on the highway anyway.


The factory headunit actually disconnects from the face so the stereo controls are still there just non-functioning.


The Hankook RS-3's are finally toast.
 
:
Mazdaspeed6
Were the speakers just direct plug and play? I read somewhere that the Bose system to replace things are a little tricky
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
I forgot to update this from last weekend. Does anyone even read this thread anymore? Anywho...

Had another track day with AutoInterests at Mid-Ohio. I achieved a personal best lap of 1:44.07 which I'm very happy about. The car has a lot of understeer so I'm getting my alignment checked and dialing in a bit more front camber.


I forgot to start recording of the fastest lap session which I'm pissed about... But this is this fastest lap I got on video of the day, a 1:46 something.
<iframe width="560" height="315" src="https://www.youtube.com/embed/qkqjbTG2mZ0" frameborder="0" allowfullscreen></iframe>


I'm very fortunate that some of my best friends also track their cars so it makes for a great day hanging out and going flat out. Also great when they offer to share their garage space and EZ-UP's/awnings. Thanks again Marc and Will!



I let one of my good friends (Will) drive Fatty and about 3 laps in we heard a "clink" sound and the front pass side got loose. It felt like the tire debeaded or something. So we came in and pulled into the garage. Notice anything peculiar in this shot?



Two of the OE studs sheared off and the other nuts were only finger tight. I'm positive I torqued the nuts Saturday when I was done wrenching, then Sunday night again after a drive. I think the heat cycles loosened the 949Racing aluminum nuts. My friend graciously let me borrow his truck (thanks, Marc!) and i went for new studs and they prepped the hub and caliper/rotor for me (thanks once again, Marc and Will!). Pounded out the broken studs and pulled the new ones in and was able to drive home. But I didn't want to track the car anymore in fear of breaking more studs or loosing a wheel. ARP extended studs and steel nuts are already ordered.

Also started my instructor training for AutoInterests. Looking forward to helping out in the track community and making sure novices have a fun and safe experience at the track.
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Fatty and I broke up. We love each other but just aren't IN LOVE with each other. A full part out has commenced.



I've met a new girl and we're madly in love and I'm very happy.

 
Top