Lewis7789 MS6 GT build thread

:
2007 mazdaspeed 3 GT
Unless you're Sho. lulz.

But interesting point, Mr. Kulish.
That was due to SU's fail boost tubes. All is fine with the stock tubes ;).
I obviously havent done any track days or autox...but upgraded top mount vs stock tmic, im seeing lower BAT's at cruising speeds and WOT as well as sitting in traffic.

What i will say for evan #2 and aj, watch your fuel pressure with the upgraded intercooler if you dont have HPFP upgrade. My stock pump would drop to 1000psi or less at any boost level over 16.5psi.

These teeny tiny k04's dont really lag though unless you have a lead foot at low RPM's, but we all know not to get into it until around 3k rpm anyways.

Edit:

I dont know how hypertech targets boost, but with the SU TMIC, Test tipe, CAI, and HPFP i was overboosting until a buddy helped me out and lowered WGDC in the earlier rpms due to the increased flow. Running the same stage 2 cobb map with the stock intercooler, i always met boost targets which was 19.5 tapering down to 17 by redline.
 
Last edited:

THE Phen

Phenda Bear
:
2013 Abarth, 2004 MSM - FM, '74 BMW Bavaria, 97 Civic EX B18C1
Lag? From a turbo that has full boost around 2500 rpm and is the size of my fist? You're silly.
 

Evan9999

Evan #2
Contributor
:
2009 MS3 GT, True Red
What i will say for evan #2 and aj, watch your fuel pressure with the upgraded intercooler if you dont have HPFP upgrade. My stock pump would drop to 1000psi or less at any boost level over 16.5psi.

These teeny tiny k04's dont really lag though unless you have a lead foot at low RPM's, but we all know not to get into it until around 3k rpm anyways.
I've been watching my fuel pressure closely and it seems like my stock pump is good enough. At WOT, I'm not seeing any drops below 1600psi. I already bought Autotech HPFP internals and they should be here by next Monday. EdgeAutoSport finally got them back in stock.
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
So I think I may have fixed that bucking/hesitation issue I was having. I removed the TMIC, battery and intake to get to the O2 sensor plug. Turns out I ordered the wrong O2 sensor (doh!). I received a Po34o code once which could be a couple things, one of them being the cam position sensor. So while I had the TMIC off I popped the cam sensor out and there was a big sludgy booger on it. I wiped it down well and replaced it, along with everything else and buttoned everything up. I've been driving the car for 2 days without a single buck/hesitation. And it seems like vacuum/boost is lower too. The car feels stronger and smoother. Hopefully that was the simple solution for that issue.

And I washed the car in the rain this morning. I'm that weird.
 

WillD

Scrooge McDuck
:
Classic Red 1991 Miata, Magnetic Gray Metallic 2014 Tacoma
Yay for fixing the bucking/hesitation! (Which I thought was you just sucking at driving until you explained. :))

And I've washed the car in the rain, best time to do it if you ask me.
 

ajkulish

Honor Super Omnia
:
2007 Mazdaspeed3 GT & 2001 SC Protege
dont you mean you took of the TMIC to give to AJ in exchange for his factory one in an even trade?
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Yeeeeaaaaah, no. How about I give you my stocker and you can superglue the two together to make a dual core intercooler?
 

ajkulish

Honor Super Omnia
:
2007 Mazdaspeed3 GT & 2001 SC Protege
Oh lord have mercy. Here we go. Engineering students gone wild.
:D

i wonder if i can weld the collector ends before the fins and all that stuff. or connect them with auxillary piping so that the air flows through both stacked intercoolers?
 

ajkulish

Honor Super Omnia
:
2007 Mazdaspeed3 GT & 2001 SC Protege
i figured hood clearance would be an issue. maybe im just thinking a little too far out there
 

Lewis7789

Evan aka "Lady Hands"
Contributor
:
1995 MX-5, 2006 MZ5, 2001 Yamaha R1
Evan, did you figure out why dsc and tcs werent working?
No, I keep forgetting to jack up the rear end and take a looksie. Honestly though, I'm in no hurry to hook them back up. It's much more fun to drive with them disabled. Until winter comes... lulz.
 
:
2003 Protege5, 2006 Mazda3, 2015 CX5
Two words... "tin snips".
Ricer/redneck hood scoop perhaps? If that were the case there would be no stacking of the IC's.Eff it, cut a huge friggin hole in your hood and stack that s***! Rice baller fo sho!
 
Last edited:

WillD

Scrooge McDuck
:
Classic Red 1991 Miata, Magnetic Gray Metallic 2014 Tacoma
Who was being sarcastic? There's no way you're going to fit 2 ICs under the hood and retain the ducting that directs airflow through them.

But enough IC talk in Evan's build thread. :D
 
Top