2016~2021 Lane assist warning issues

Hello, I have a 2020 Cx-9 Grand Touring purchased August 2020 but I am having issues with my lane assist warning. The system is going in and out for the last week. Anyone else have it had any issues? Car at dealership now?
 
:
Ft Worth
:
2021 CX9 Signature
What do you mean ‘in and out?’

Is the system ON with the button left of the steering wheel?
Also understand the car has to identify the road lines for the system to work. This can be tricky at times, with bad pavement, or on some curves. If there are no straight vertical lines next to you car icon on the display (or HUD) the lane assist and warning system won’t work. That means it hasn’t detected the road lines.

A5E2D90D-3C27-46B3-BD9F-2252120AB5F3.jpeg
 
What do you mean ‘in and out?’
Is the system ON with the button left of the steering wheel?
Also understand the car has to identify the road lines for the system to work. This can be tricky at times, with bad pavement, or on some curves. If there are no straight vertical lines next to you car icon on the display (or HUD) the lane assist and warning system won’t work. That means it hasn’t detected the road lines.
View attachment 234418

The system works sometimes but not all the time. I drive the same route daily and in the last week my lane warning is not warning neither is the hands on steering wheel. Previously if my car just drifted slightly the warning or steer wheel would nudge, now nothing. I previously had this same issue about 3 weeks ago along with my active display not working. I am scheduled to take it to the dealership on Saturday just trying to figure out if anyone else had this issue and what could be the problem why I keeps having to take into the dealership?
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
As Buster1 mentioned, the system only intervenes if lane lines are detected. If lane lines are not being detected, it could be as simple as a dirty windshield, or a malfunctioning windshield camera. If the lane lines are there in the HUD/instrument cluster and the car doesn't provide a warning or a nudge, something else could be malfunctioning.

I separated these posts from the original thread and created a new thread for you.
 
Top