Issue with 2013 Mazda 2 - Rough Idle, Shaking

:
Mazda3
hey guys.

have any of you come across this issue.
my mothers car developed a very rough idle, engine shaking issue. Car is a 2013 Mazda2 DE 1.5L with 50,000km on it. Always serviced and looked after etc.

Basically after the car warms up but not reach super hot temp (eg 95-100 Celsius coolant temp), when the car is stopped and in D with the brake applied, the engine idles very very rough, shakes, almost if its misfiring. if you put it in N/P the rough idle is still there but not as bad but still noticeable.

putting air con on, sort of alleviates the problem. however when the car is full hot, where the radiator fans come on and off, then the rough idling seems to be gone. The car idles roughly 650-700rpm in N/P and around 550rpm when in D

i've checked the spark plugs, ignition coils, and the egr using the resistance values, as specified in the mazda workshop manual and they seem to be ok. I'm thinking of changing the spark plugs, but before i do that i thought i would ask here.
I've done a fault code scan using a generic scan tool (torque) and no fault codes found either.

any ideas? anyone else had the same issue?
 
:
Mazda3
doing few more tests, especially when this rough idle/engine shaking happens if i unplug the EGR valve the shaking stops.
So it looks like it could be the EGR valve.
anyway has anyone else had to replace theirs or had issues with it before?
 
:
Mazda3
replaced egr valve.... initially through the issue was resolved, but still there...however it does seem not as bad.....but that could be placebo effect.
i've also been using 98 RON petrol for the past 2 tank fulls.
anyway have dropped it off at a mazda dealer to see if they can find anything out. however after using the scan tool FORScan I cant see anything thats not working out of place.
maybe the ECU/PCM needs a update.?.. well wait and see.
 
:
Mazda3
dealers... i really dont have faith in them...just like i assumed they didnt find anything...but wait they said the drivers front side engine mount is no good and causing engine shaking...lol..how pathetic. oh well looks like its time to take mazda to court....
 
:
Mazda 2 Sport (2008)
I recently replaced the left side engine mount and cleaned the MAF sensor on my Mazda 2 2008, The engine was shaking and rattling like hell, and the idle wasn't very stable (Dropped from 700 rpm to 500 a lot of times). After those changes the engine it's running smooth, but sometimes it's idle gets unstable (Fewer times than before). The main problem, at least on the 2008 model was that the engine mount failed early (Mine filed at 80.000km). I don't know if they fixed that problem on the 2013 model.

So I recommend to check the engine mounts (Especially the passenger side one). Here's a photo of the culprit:

https://imgur.com/a/sanPSYP
 
:
Mazda3
well good thing is mazda has come to the party and is going to replace the engine mount free of charge.. so well see what happens after that
 
Top