image icon not updating for XM stations

:
2016.5 Mazda CX-5 GT AWD w/Tech
Double checked the versions:

OS 70.00.100
Music DB 00.08.000
Fail Safe 70.00.100

That looks right. Have you been seeing XM station and music art? Sounds like it but was wondering if you are seeing it on different channels? I see you mentioned it looks like it got hung on some art recently. Where it didn't change/update when the music changed. I've seen this happen once and a while on a local FM HD station. Odd. It'll hang for a day or two and then be fine for some time. Haven't seen it occur elsewhere (stations).
 
:
2019 CX5 Reserve AWD
That looks right. Have you been seeing XM station and music art? Sounds like it but was wondering if you are seeing it on different channels? I see you mentioned it looks like it got hung on some art recently. Where it didn't change/update when the music changed. I've seen this happen once and a while on a local FM HD station. Odd. It'll hang for a day or two and then be fine for some time. Haven't seen it occur elsewhere (stations).

Yes, album art appears on all the XM stations I listen to. I've only noticed one occurrence of the art/song title not changing when the track changed.
 
:
2016.5 Mazda CX-5 GT AWD w/Tech
Update:

Well, I have the 2016.5 GT. I have NOT upgraded my USB hub. I opted to upgrade the f/w to 70.00.100 as newer CX 5 models appeared to be getting XM radio artwork for stations and album art (see above). I had done some research on this and verified with a few ('18 and '19 year models, running 70.00.100). BUT, I didn't have luck on this. Bummer. Sounded as though the newer f/w (v70) had added a lot for XM radio code.
 
Top