2007~2015 High mileage and parts breaking?

:
mazda cx-9, lux
hi all. i have an 09 cx9 with a 170k miles on it. so far the only problem that i have had was a water pump break at 80k. cv joints are a little noisy and window motors died and ac just started to blow hot because i think that i have a leak in the fan box area. but in all, nothing else has let go.
just wondered if anyone has high mileage and lost major components.

thanks
tony
 
:
2014 Ford Explorer Sport, 2009 CX9(Wife's)
My wife's 09 CX9 has just over 170k miles.

2 dealer completed repairs:
PTU leaked and was replaced @ ~130k miles.
Forgot one rear wheel bearing went out around shortly before PTU (~120k miles).

All below was done by me:
Front brakes replaced a few times, rears replaced once.
Struts and shocks replaced earlier this year.
Front passenger window is stripped....mainly due to 3yr old hanging on a partially open window.
Couple sets of tires.

Other than the PTU, no other major issues and mostly just normal maintenance.
Also, original water pump (this does have me worried).
AC still works.
 
:
2010 CX-9 GT
hi all. i have an 09 cx9 with a 170k miles on it. so far the only problem that i have had was a water pump break at 80k. cv joints are a little noisy and window motors died and ac just started to blow hot because i think that i have a leak in the fan box area. but in all, nothing else has let go.
just wondered if anyone has high mileage and lost major components.

thanks
tony
List of problems, 2010 GT:
Both front power window motors went bad
Front AC blower failed due to drain clog
Blower relay died
Pressure sensor for evaporative emissions system failed
Rear wheel bearing went bad
Brake rotors/pads developed vibration, had to replace
 
:
2010 CX-9 GT AWD
My 2010 GT is at 110K but no problem so far.
Saw a little leak on engine but haven't figured out where it from.
I changed myself transfer case oil at 100K but only done 6 pumps and refills, still need more.
I changed rear differential oil at 100K too, but old one looked as new.
BT sometimes not connected but it works after a restart.

hi all. i have an 09 cx9 with a 170k miles on it. so far the only problem that i have had was a water pump break at 80k. cv joints are a little noisy and window motors died and ac just started to blow hot because i think that i have a leak in the fan box area. but in all, nothing else has let go.
just wondered if anyone has high mileage and lost major components.

thanks
tony
 
:
mazda cx-9, lux
anyone done plugs and wires?
has anyone replaced their remote? i lost one and just down to one now and bought what i thought would work as a replacement but didnt.
nice to see others with high miles. anyone over 200?
i plan on keeping it until it dies

thanks
tony
 
:
'11 Mazda CX-9 GT AWD
anyone done plugs and wires?
i did the plugs at 110k miles or so. they looked fine; i think i posted my experience on here. no need to do "wires" in modern vehicles with coil on plugs. the rears were tough to get to but just takes patience and the right extensions.

we are at 145k miles now. PTU was replaced under warranty. i also replaced rear shocks around 80-90k miles; that was an experience. tedious. we just had the front struts replaced, took it to a shop; we did KYB all around. other than brakes, tires, filters, and oil changes that has been it!
 
Hello Tony,

I was wondering how did you noticed you had to replaced your water pump. I'm aware that this is an internal water pump and it is kind of difficult to noticed if is going bad. My 2010 CX9 just hit 150k miles and I've only replaced front wheel bearings and brakes.
 
My '08 CX-9 has around 220k miles. Changed water pump, radiator, valve cover gaskets, front wheel bearings, and all three motor mounts. The front ball joints were replaced by Mazda under the recall a while back. Need to replace the transmission axle seals next. But all in all, I haven't done that much in 220k.
 
Top