Fresh Sweet Donuts Everywhere! (work log)

323

(u_u) ...zZzZzzz
Moderator
I have a catch can and have installed and removed it twice from it leaking under boost. It sprays a mist of oil in the engine compartment.

Luckily mine seals very well. I did experience leaking with an eBay greddy style knock off catch can. Going to turn it into a piggy bank in the future since it’s useless. Tried sealing it numerous times but it continued to leak
 

323

(u_u) ...zZzZzzz
Moderator
replaced valve cover and pcv valve. shook the old pcv valve and couldn't hear the check valve rattling so that must've been a big part of my problem. went for a test drive and the top side is now dry. bottom still had some oil but not enough where it dripped onto the ground. it made the undercarriage covers wet. changed out the dip stick tube o ring (which didn't look that bad to me really), cleaned it all up and now the leak stopped. im happy it was the dipstick tube and not the front main seal.
 

hornsfan10609

Certified Mazda Tech
:
2003.5 Mazdaspeed Protege x2
Good to hear, I have had the dipstick leak on me as well. Easy fix though. Cobb will be selling air-oil separators soon for Subarus, I think I will try to make one work on my MSP. My cheap weapon R one doesn't seem to work very well.
 

323

(u_u) ...zZzZzzz
Moderator
yeah, oil leaks are not fun to deal with. i was just under the car about 20 minutes ago doing a checkup on the leaks. appears to be good. i just skimmed through my own thread and all them oil leaks are so sad lol. it's been a while since pictures were posted so here's a pic of my car with my friend's nissan laurel. everybody likes pictures!





 
Last edited:

323

(u_u) ...zZzZzzz
Moderator
got an oil temp gauge coming soon so i'll be moving the gauges around. here's how they currently sit. my freshly powder coated valve cover will be in soon too



 

323

(u_u) ...zZzZzzz
Moderator
I didn’t arrange all of them for the picture. They’re for the valve cover. I got a set but with two colors so I got enough for two cars lol.

Oh yeah it was really cold today and my cold oil pressure at idle hit 75psi when I started it up compared to the usual ~68psi.
 

323

(u_u) ...zZzZzzz
Moderator
installed the valve cover today. the color is strange in dimmer light but i like it. it almost appears to be a deep red. in fair lighting it just looks like a piece of chocolate. when it's bright, you'll see the bronze like you do in the photos above.

old vs new



installed with new hardware washer and bolts to dress it up a bit.



i broke my old pcv grommet lol. it was old and brittle anyway.

 

323

(u_u) ...zZzZzzz
Moderator
at 126,800 miles:

  • installed new battery
  • swapped out rear 4K springs to 6K
  • hooked up oil temp gauge
  • flushed brake fluid
  • drained and refilled coolant
  • installed wrx 440cc injectors
 
Last edited:

323

(u_u) ...zZzZzzz
Moderator
since my last update, been trying to get a decent tune going. it went OK at first, then I got the hang of it. suddenly my AFR's just went rich no matter what i did. found an exhaust leak on the turbo manifold as all my bolts were loose and one was missing. fixed that. i managed to get one decent tune in but randomly the car would hesitate under boost. eventually the random occurrences became normal. the weather got cold and i had other things to deal with so i let it sit for a bit. this week it finally threw a code for p0660 (vics solenoid). it was completely dead. swapped in a spare and it seems good so far cause it isn't hesitating under boost anymore. why did it take this long for a code to pop up? lol ...... :|
 

323

(u_u) ...zZzZzzz
Moderator
dear diary, i did a boost leak test on saturday by capping off the intake pipe and pumping air into it. sprayed around with soapy water and found my tps sensor is leaking lol. looking at a spare throttle body, it has an O ring which i discovered that you cannot buy separately. went ahead and ordered a cheap ebay tps sensor since it comes with an O ring just to get the O ring. if that doesn't work still then i guess i'll be RTVing the son of a bish.

since i'm on a streak with finding all these random leaks, i should be done by christmas now. right Damian?
 

Dpwhitehead1

Damian
Contributor
:
MSP 1145
dear diary, i did a boost leak test on saturday by capping off the intake pipe and pumping air into it. sprayed around with soapy water and found my tps sensor is leaking lol. looking at a spare throttle body, it has an O ring which i discovered that you cannot buy separately. went ahead and ordered a cheap ebay tps sensor since it comes with an O ring just to get the O ring. if that doesn't work still then i guess i'll be RTVing the son of a bish.

since i'm on a streak with finding all these random leaks, i should be done by christmas now. right Damian?

Maybe by Christmas... hopefully June.

Dear Philips' diary,

the severe lack of pictures on this site is frustrating. Every time I see the thread name, I want donuts.
 

323

(u_u) ...zZzZzzz
Moderator
Dear Damian’s health, this thread is truly sorry lol

You like this thread filled with pictures of leaks and sadness? Haha
 

Keno1542

Yellow Jacket
:
Mazda MP3
Orings are cheap. Measure old one with calipers and buy the oring. Several online stores that specialize in orings and have a ton of info on how to measure your orings for replacement
 
:
2003.5 MSP
dear diary, i did a boost leak test on saturday by capping off the intake pipe and pumping air into it. sprayed around with soapy water and found my tps sensor is leaking lol. looking at a spare throttle body, it has an O ring which i discovered that you cannot buy separately. went ahead and ordered a cheap ebay tps sensor since it comes with an O ring just to get the O ring. if that doesn't work still then i guess i'll be RTVing the son of a bish.

since i'm on a streak with finding all these random leaks, i should be done by christmas now. right Damian?

I can guarantee you will also have a boost/vacuum leak underneath the return spring on your throttle body.. There's a tiny shaft seal underneath there and it'll be dry rotted from age. I've rebuilt a couple tb's and have the dimensions written down somewhere. Will post info up later if your interested.
 

323

(u_u) ...zZzZzzz
Moderator
I can guarantee you will also have a boost/vacuum leak underneath the return spring on your throttle body.. There's a tiny shaft seal underneath there and it'll be dry rotted from age. I've rebuilt a couple tb's and have the dimensions written down somewhere. Will post info up later if your interested.

i've encountered this issue about 5-6 years ago. i replaced it with another used tb and it's been good ever since. BUT, i will be keeping my eye out that pos. the original tb is still in my possession so i could rebuild that one.

Orings are cheap. Measure old one with calipers and buy the oring. Several online stores that specialize in orings and have a ton of info on how to measure your orings for replacement

i'll keep that in mind for next time. any specialized o ring website you suggest?
 

Keno1542

Yellow Jacket
:
Mazda MP3
Ive used these guys a few times for car and other orings. They are reasonable on prices and shipping and ship super fast. I always order a few sizes in case my measurements are off one way or the other, the orings are so cheap, it is worth it in my opinion.
 

323

(u_u) ...zZzZzzz
Moderator
Ive used these guys a few times for car and other orings. They are reasonable on prices and shipping and ship super fast. I always order a few sizes in case my measurements are off one way or the other, the orings are so cheap, it is worth it in my opinion.

did you forget to post the site? lol. i replaced the o ring last night. the o ring itself is so thin that im surprised it actually does anything lol. those two screws on the TPS are a pain to get to without taking the TB off but i got it done. no more leaks from that area.
 
Top