CX-5 Android Auto / Apple CarPlay

I purchased a 2020 CX-5 a month ago (my first Mazda, I am a Honda girl), today I took it in and inquired why it would not work with my phone. I was told that Mazda and Google Pixel phones are NOT compatible! The dealer knew I had a Google phone - has anyone else had this problem and is there any work around? I am really upset.
 
:
2019 CX-5 GTR
@ariel5017 - Im not sure what exact problem you are having..

a quick few quick searches found..

https://www.reddit.com/r/AndroidAuto/comments/dp4oo0
and this gem:

looks like you might not be alone

the official documentation from Android Auto is the Mazda CX-5 2019 and forward IS supported

though the Mazda side is less than assuring

some Mazda related reading:
 
:
NYC
:
2017 CX-5 GT AWD
I purchased a 2020 CX-5 a month ago (my first Mazda, I am a Honda girl), today I took it in and inquired why it would not work with my phone. I was told that Mazda and Google Pixel phones are NOT compatible! The dealer knew I had a Google phone - has anyone else had this problem and is there any work around? I am really upset.
Which Pixel phone do you have?
I have connected with our Pixel 2 XL, Pixel 3a XL, and the Pixel 4 XL -- all work with Android Auto.
 

amalraj

FromTheBayou
:
2019 CX-5 Sig
I purchased a 2020 CX-5 a month ago (my first Mazda, I am a Honda girl), today I took it in and inquired why it would not work with my phone. I was told that Mazda and Google Pixel phones are NOT compatible! The dealer knew I had a Google phone - has anyone else had this problem and is there any work around? I am really upset.
Hmm...not sure this is true. I have a pixel 2XL which works flawlessly. My wife has a Pixel 3a which does too. Also to note that from a software point of view my pixel is no different from a pixel 4, aside from a few camera things, considering I am running the latest beta for Android 11. So technically even if you own a 4 it should work. Is you issue with Bluetooth or is it with Android Auto? If it's Bluetooth then delete the vehicle profile and remove the device from the car settings and then add it back. If it's only AA, then are u connecting to the correct AA port?
 
:
'20 CX-5 Signature
I also have a Pixel 2XL which works with my car.

Unrelated, is there not a way through android auto to view my text messages? If I get a text message while driving the car will read it to me and I can reply of course, but is there no app that will let you pull up all your SMS messages so you can read them? I get they wouldn't want you messing around with it while driving but even if the car is stopped?

And I'm guessing none of them will display a photo? I was driving and got a MMS (my phone wasn't plugged in so the native Mazda thing took over) and the system showed "Message type not supported" and when the voice read it back to me it just read the filename which was amusing.
 
So I am upgrading my 2018 from 59.xx to 70.00.367A and one place said I need to do the 70.00.100 update first(failsafe and big file) and others say I can just go straight to the latest and skip the failsafe step. Anyone do this yet? I'd prefer to just do one install.
 
:
2016.5 Mazda CX-5 GT AWD w/Tech
I also have a Pixel 2XL which works with my car.

Unrelated, is there not a way through android auto to view my text messages? If I get a text message while driving the car will read it to me and I can reply of course, but is there no app that will let you pull up all your SMS messages so you can read them? I get they wouldn't want you messing around with it while driving but even if the car is stopped?

And I'm guessing none of them will display a photo? I was driving and got a MMS (my phone wasn't plugged in so the native Mazda thing took over) and the system showed "Message type not supported" and when the voice read it back to me it just read the filename which was amusing.
The AIO Tweak can be set up to do so.
 
Just bought a used cx-5 2019 GT. Apple carplay seems to be acting up for me. At start up, I cannot plug in my iphone until waiting maybe 2-3 minutes for it to be recognized. If I plug in prior to start up, carplay never loads on the infotainment screen. I've tried 2 different apple oem lightning cables, my girlfriend's iPhone, updating to the most recent firmware.

Carplay has only quit on me with the "Mobile Device Error. Apple CarPlay is not responding." error message once. The problem seems to be with the initial connection. Sometimes I get the error message: "application change failed to load". I haven't been able to find any info on this error message anywhere on the internet.

Is this normal? If not, what can I do to fix it? I've called all my local Mazda dealerships and none of the service managers know where to go from here. Should I ask them to replace the usb ports? Would this be covered under the basic 3 year warranty?
 
So I am upgrading my 2018 from 59.xx to 70.00.367A and one place said I need to do the 70.00.100 update first(failsafe and big file) and others say I can just go straight to the latest and skip the failsafe step. Anyone do this yet? I'd prefer to just do one install.
Hey Frank did you install the Tweak after going to 367A? I just got my CarPlay and was thinking about the tweak but not sure..
 
My wife just bought a 2020 CX-5 and can't connect her Android Auto to her Motorola Moto Z3 phone? The dealer connected his phone but hers wouldn't work. Suggestions?
 
Last edited:
:
'20 CX-5 Signature
My wife just bought a 2020 CX-5 and can't connect her Android Auto to her Motorola Moto Z3 phone? The dealer connected his phone but hers wouldn't work. Suggestions?
If they didn't use the same usb cable then make sure she doesn't have a bad USB cable. If they were the same, make sure she doesn't have her phone configured to only charge when connected via USB.
 
:
2019 CX-5 Signature
My wife just bought a 2020 CX-5 and can't connect her Android Auto to her Motorola Moto Z3 phone? The dealer connected his phone but hers wouldn't work. Suggestions?
I have a Z2 and my wife has a Z3. Both work fine with AA. There are steps you need to follow to get it going. The first being loading the app. :)
 
:
2019 CX-5 Signature
The apps were loaded prior to attempting to connect. I went to a Motorola forum to get info but that didn't work either.
It's not a Motorola issue. If you can't figure it out by using the owner's manual, you should take it to your dealer. They should be able to connect it for you in a few minutes.
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
If they didn't use the same usb cable then make sure she doesn't have a bad USB cable. If they were the same, make sure she doesn't have her phone configured to only charge when connected via USB.
Check this, there was a post recently where an owner was having trouble re-enabling AA on his 2020 CX-5. He was trying to troubleshoot an issue and disabled AA from the Infotainment, which put his phone into "Charge only" mode. He switched it back to "Data transfer" mode on his phone and was able to re-enable AA. Maybe that will fix your issue too.
 
:
2019 CX-5 Signature
Check this, there was a post recently where an owner was having trouble re-enabling AA on his 2020 CX-5. He was trying to troubleshoot an issue and disabled AA from the Infotainment, which put his phone into "Charge only" mode. He switched it back to "Data transfer" mode on his phone and was able to re-enable AA. Maybe that will fix your issue too.
When I plug mine into a computer, it shows "USB Charging" mode. When I plug it into our CX-5 and select the phone in the menu, it comes up in AA mode. I have never had to change it to data transfer to work with AA?
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
When I plug mine into a computer, it shows "USB Charging" mode. When I plug it into our CX-5 and select the phone in the menu, it comes up in AA mode. I have never had to change it to data transfer to work with AA?
It's just something to try. In the post I referenced, disabling AA from the infotainment put the phone into "charge-only" mode. Likely what happened is that the car/phone now recognizes that USB device/port as "charge-only", and defaults to that mode when it is connected via USB. Yours may have always defaulted to data transfer because you've never had to change it.

This is less likely to work in this case as it sounds like Guswhite's wife has never used her phone with the CX-5 before, but it may be worth checking nonetheless.
 

7eregrine

The man, the myth, the legend
:
Land of Cleve
:
2016.5 CX5
AA should absolutely work with every phone listed in this thread. You should not need to switch modes when you connect. One thing to try is removing and reinstalling the app on your phone. Reboot in between just because. As mentioned cables are sometimes an issue, too. There are cables that do not pass data, only charge devices. Those won't work.
 
Top