Broken Heater/HVAC... Replaced blower motor, resistor & relay. STILL NO AIR!

:
2003 Mazda Protege5
If anyone else has this issue and can't find the connector ANYWHERE. I found this

I had the melted connector too, and ended up just trimming an inch or so (the corrupted copper) off the harness. Soldering new blade females onto the existing wiring, then plugged directly to the new switch. But I think I found the connector (too late to help me, but can possibly help you.)

http://www.aliexpress.com/item/10-set-6-3mm-6P-6-Way-pin-Electrical-Connector-Kits-Male-Female-socket-plug-for/2021804597.html

Hope this helps.

I thought "surely this 6 position, 2 row, latch connector is going to be a snap to find", and I was mistaken.
 
:
2002 Protege5
I had the melted connector too, and ended up just trimming an inch or so (the corrupted copper) off the harness. Soldering new blade females onto the existing wiring, then plugged directly to the new switch. But I think I found the connector (too late to help me, but can possibly help you.)

http://www.aliexpress.com/item/10-set-6-3mm-6P-6-Way-pin-Electrical-Connector-Kits-Male-Female-socket-plug-for/2021804597.html

Hope this helps.

I thought "surely this 6 position, 2 row, latch connector is going to be a snap to find", and I was mistaken.
Wow nice find! Are u sure it's the right size? Sorry...just dbl checking b4 I grab....

http://g01.a.alicdn.com/kf/HTB1gM7H...dth=500&hash=0acfbbaee29de440b243aa9e5a15be8d

Sent from my VS985 4G using Tapatalk
 

pcb

The Diagram Dude
:
2002 MP5
I say just use these...






Or these...





Your new plastic connector may melt again...

These ones breathe to dissipate heat. .
 

pcb

The Diagram Dude
:
2002 MP5
PS... If any of the metal connectors touch each other or touch ground, it doesn't matter...

It just means your fan may come on.... You won't pop any fuses or blow shit up.
 

pcb

The Diagram Dude
:
2002 MP5
Here's some rough diagrams if anyone wants to use relays for their fan switch...



 
:
2003 mazda protege5
We'res the blower motor relay

So this is getting really annoying...

One morning I started my car and my heater wouldn't turn on--no air, nothing. I left the console controls ON at setting 4 even though it wasn't working. After driving for several minutes it *magically* turned ON and I was greeted with a nice blast of hot air.

I assumed a finicky Mazda electrical system was being affected by the cold weather.

For several days this happened. I would start the car, drive until the cabin was somewhat warmer and then *BOOM* the heater would "fix" itself and turn on.

Sometimes I fiddled with the control console dials when it wasn't working. Leaving it at 0, then twisting it to 1-2-3-4 and back, or switching to defrost/main-vents/feet etc. trying to see if I could get it to activate. Several times it would turn on during my *fiddling* or if I hit a sharp pot-hole in the road.

Then one day it never came on. It has been broken completely for over a month now.

I replaced the Blower Relay first. Nothing. I then replaced the Blower Motor--hoping to go for the jugular. Nothing. Finally I replaced the Resistor--even though I was certain this was not the problem. Nothing.

Ugh. Replace the console controls next?

Any advice?

We're is the blower motor relay?..I've checked the switch and it's good and replaced the resistor
 
Top