2017 GT - Multiple Malfunction Messages

V
2017 CX5 GT
Hi,

Received the following messages today in succession on the instrument cluster.
Front Camera Sensor System Malfunction
Smart Brake System Malfunction
Forward Smart City Brake System Malfunction

Yesterday I got a Front Radar system blocked message (which cleared with an engine stop and start, I also wiped dirt off the emblem where radar detector is behind).

All messages today cleared with a stop and start of the engine

Will be scheduling a service appointment but any input into what might be going on, would be appreciated. Car has <200 miles.
 
V
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
Make sure the camera behind the rear vision mirror (mounted on your windscreen) is also clean as that controls Smart City Brake System and Smart Brake System

BTW - did this occur during snow event (uhm) (I am unsure if it is snowing where you are)
 
V
2017 CX5 GT
Thanks Xelerbing, yesterdays message for Front Radar system blocked was during snow. No snow today for all other messages, will be sure all is clean as suggested..
 
V
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
Thanks Xelerbing, yesterdays message for Front Radar system blocked was during snow. No snow today for all other messages, will be sure all is clean as suggested..
No worries.

I think these systems have issues with snow. Seen someone mention this previously
 
V
2017 CX-5 GT
I bought my cx-5 GT in late October and I encountered the same problem when the car was two weeks old. I was driving one morning when a message suddenly popped out saying "Front Camera Blocked, Defog Windshield Completely". It was clear and sunny and the windshield was in fact perfectly clean. Later that day when I restarted the car, I got a series of different messages including "Front Camera Sensor System Malfunction", "Mazda Radar Cruise Control Disabled", "Smart Brake System Malfunction", and "Forward Smart City Brake Support Malfunction". These messages have not appeared ever since despite having gone through rain and snow (yes, it snowed here in Texas for the first time in almost 8 years!). I haven't had time to bring the car back to dealer for inspection and I will be watching this thread with interest.
 
L
NYC
V
2017 CX-5 GT AWD
Ours popped up "Front Radar Sensor Blocked" driving home in the snow (we got ~4"). Cleared a light dusting off after getting home. Hasn't popped up since, don't know if that was it.
 
L
GA prior 16 CX5 GT
V
20 CX5 GT + Prem
I have had similar messages when there was high moisture on the inside of the window perhaps blocking the camera that drives the safety systems. Defrost and it went away.
 
V
2014 CX-5 GT w/ Tech
Hi,

Received the following messages today in succession on the instrument cluster.
Front Camera Sensor System Malfunction
Smart Brake System Malfunction
Forward Smart City Brake System Malfunction

Yesterday I got a Front Radar system blocked message (which cleared with an engine stop and start, I also wiped dirt off the emblem where radar detector is behind).

All messages today cleared with a stop and start of the engine

Will be scheduling a service appointment but any input into what might be going on, would be appreciated. Car has <200 miles.
I had the same issue and my camera module was replaced.
 
V
2017 Mazda CX-5 GT
Hi,

Received the following messages today in succession on the instrument cluster.
Front Camera Sensor System Malfunction
Smart Brake System Malfunction
Forward Smart City Brake System Malfunction

Yesterday I got a Front Radar system blocked message (which cleared with an engine stop and start, I also wiped dirt off the emblem where radar detector is behind).

All messages today cleared with a stop and start of the engine

Will be scheduling a service appointment but any input into what might be going on, would be appreciated. Car has <200 miles.
Like others have said make sure your windshield is clean where you rear view mirror is, if it's dirty or covered with ice, snow etc, it will shut off the systems and warn you that there is a problem.
 
V
'17 AWD CX-5 GT w/ Premium Package
I received those errors this morning for the first time. Ive had my CX5 for two months. I checked the windshield and didn't see any dirt or debris on the glass. The car is also garaged over night and it was a nice/sunny morning. If the errors still appear after work I will make a service appointment.
 
V
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
I received those errors this morning for the first time. Ive had my CX5 for two months. I checked the windshield and didn't see any dirt or debris on the glass. The car is also garaged over night and it was a nice/sunny morning. If the errors still appear after work I will make a service appointment.
See my post in your thread
 

TgR

V
2018 CX5 GT
2018 CX5 GT. Only 46 miles. Dashboard lit up with error messages. Front camera sensor error mulfunction. Forward smart city brake malfunction. Smart brake system malfunction. Its 50 degrees outside and sunny. I pulled over and shut car down for a minute. Started again with no warnings. 3 minutes later dashboard lit up again. It comes and goes. I am taking it back to the dealer and will post what they tell me. This is my 3rd Mazda. Never had to take one back after 46 miles !!
 
V
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
2018 CX5 GT. Only 46 miles. Dashboard lit up with error messages. Front camera sensor error mulfunction. Forward smart city brake malfunction. Smart brake system malfunction. It’s 50 degrees outside and sunny. I pulled over and shut car down for a minute. Started again with no warnings. 3 minutes later dashboard lit up again. It comes and goes. I am taking it back to the dealer and will post what they tell me. This is my 3rd Mazda. Never had to take one back after 46 miles !!
Anything on your windshield where the camera is (uhm)
 
V
CX-5 GT
Just had this happen to my '17GT 2 days ago. While it was a little cold out (-18 celcius without windchill, -27 with), the car had been washed the day before so everything was spotless. Nothing obstructing the camera.

I was parked and there was no snow or direct sunlight but it just kept cycling through all the errors. Turning the car off, waiting a minute or two, then turning it back on didn't clear it.

Took a video the display cycling through the warning messages - Sorry, not sure why it jumps around so much. It went away later in the day, on it's own.

 
Last edited:

shadonoz

SkyActiv Member
Contributor
L
State of Jefferson
V
2017 CX-5 GT AWD+
It's starting to sound like washing these cars when it's so cold may not be the best idea....
A lot of problems seem to to occurring right afterwards.
 
V
CX-5 GT
It might just be "cold" that it doesn't like (which would be super unfortunate)... The car was washed the day before, then kept in a nice warm garage overnight.
 
V
'18 Mazda CX-5 Akera KG i-Activ AWD 2.5L In Sonic Silver
I would suggest all the owners experiencing this issue report it to Mazda NO HQ so a TSB with a solution is released
 

shadonoz

SkyActiv Member
Contributor
L
State of Jefferson
V
2017 CX-5 GT AWD+
I'm thinking that high pressure water may be getting somewhere that it shouldn't, somewhere that should be protected from the water but isn't. Then when it goes out in the cold, even a day later, the water freezes....
 

Latest posts

Top