2016 CX-9 GT noise when braking

Very weird only One time click noise when coming to a stop after first start the car after some pause. Noted the noise when changing directions. For example, if I park backwards in the garage and next day start the car and move it out of the garage and hit the brake, I can hear clearly the click. It is only once. After that it is not to hear as long not changing directions. Like if I am backing up and push the brake, will click again only the first time. After that it stops fine, but no sound or noise.
Today I rotated the tires and checked the calipers, all are rock solid, no movement. This is why I start thinking it could be the drive shaft or the transmission. The vehicle is FWD only!
So, anyone heard of something like this?
 
youri, you are the man. Thanks for pointing out to this TBS. I think the problem is defined well and applies to what I have here.
Does Mazda fix this problem under warranty or owner still pays for it?
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
So I took my car in for this issue yesterday (brakes clicking, low speed squealing). They tested and verified that the issue exists, referenced the TSB posted in this thread, then ordered the parts required to resolve the issue. Apparently they didn't have any parts on hand because this is the first time they have had this issue. I'll have to bring the car back in once the parts arrive.

Edit: Forgot to mention that the work order says I'll get new front brake pads and shims for the front and rear.
 
Last edited:

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
Did you pay for the repair?

Repair hasn't happened yet. Still waiting on the parts. I'm actually going to follow up with them today.

Based on what the service rep said, everything should be covered under warranty. I'll post here when the repair has been completed.
 

sm1ke

Work In Progress..
Moderator
Contributor
:
Canada
:
'18 CX-9 Signature
New brake pads and shims were finally installed yesterday, but the tech says that the noise persists. I haven't been able to replicate it yet, but I've only had the car back for a day so far. Parts and labour were covered under warranty. They want me to bring it back in.
 

Latest posts

Top