2008 Aux in stopped working - can't figure out solution

:
Mazda cx9
2008 Mazda CX-9 with Bose stereo and no DVD

Aux always worked perfect until a month ago

Now when pressing aux butting nothing happens

Replaced 3.5mm male to make cable and this did not solve the problem

Then replaced the aux in part inside the center console and this didn't solve the problem

Really don't know what next step is now

Any help is greatly appreciated.
 
:
CX-9 2013 AWD
2008 Mazda CX-9 with Bose stereo and no DVD

Aux always worked perfect until a month ago

Now when pressing aux butting nothing happens

Replaced 3.5mm male to make cable and this did not solve the problem

Then replaced the aux in part inside the center console and this didn't solve the problem

Really don't know what next step is now

Any help is greatly appreciated.

you didn't happen to subscribe to XM or Sirius radio or install IPOD cable recently did you ?

seems like the AUX is disabled if SAT radio or IPOD is detected, I know total bull$??? !
if you subscribe to SAT, the AUX gets disabled, I think this was only on 2007 and 2008 models.
The SAT radio or IPOD runs thru the AUX port and there's only one AUX line.

if you didn't subscribe, it maybe a faulty sensor, indicating to head unit there's a SAT radio when there's not but AUX is disabled.
is your AUX button "greyed out" on the screen (if it is, then that's bad news and unfortunately it's the sensor shutting the AUX mode down)

if it's not, then that's good news and sensor is fine and it's a hardware/cable problem,
try connecting other sources, like a cheap standalone radio via the line in cable to the AUX port
and see if anything goes thru the speakers.

see links :

http://www.mazdas247.com/forum/archive/index.php/t-123739189.html

https://zeusville.wordpress.com/2008/04/15/sirius-satellite-radio-and-aux-input-not/
 
Last edited:

sjg

:
2009 CX-9 Touring AWD
I had the AM radio just stop working. (Yes, I occasionally listen to AM.) Dealer had to replace. Got the repair done just before my 100K mile warranty expired.
 
:
Mazda CX-9
2008 CX-9 Media button error

I'm not sure if I'm having the same issue but I haven't been able to fix it yet.
My Aux/Media button won't switch back and forth. It's stuck on Media, which activates the sound for the DVD player. I never had any problems in the past and it just quit on me one day.
Some notes.. I don't have the SAT radio on Guam and have never used it either. I've always been able to switch to AUX feature in the past, whether there was an AUX cord plugged in or not. When I press Media, there is no pause, no searching or loading delay. It just stays on Media as if it's a single purpose button. I have not pulled out the player or checked any wires yet, and don't plan to until I find a sure solution for the problem. And lastly, the battery has been disconnected and reconnected many times, and it did not reset the issue.
I think that about covers all the 'solutions' I've read on other threads. Anyone have any suggestions?? It's been about 2 years and I'm kinda missing my music.