'19 Signature shudder just after stopping from highway speeds

V
2019 CX-5 Signature Soul Red Crystal Metallic
Title says it, but Ill try to be more specific.

Car has about 19,000km on it and is almost 1 year old.

After driving at highway speeds (100-120km/hr) for a short period of time (20 mins), I've noticed that AFTER having come to a complete stop, the RPM's return to idle but shortly thereafter, there is a noticeable shudder in the car, ALMOST like the car is going to stall.

It's not terribly pronounced, but it's enough that everytime it happens I go"uh oh..".

Has anyone come across this?
 
V
2019 CX5 Signature
Sorry I can’t help...but will add another datapoint. My 2019 Sig w/1,900 miles has never demonstrated that behavior. Hope you get it sorted out soon.
 
V
2018 Mazda6 Signature
I am dealing with this on my 2018 Mazda6 Signature (2.5T engine) as well. Dealer is currently troubleshooting and working with Mazda Canada on fixing it. They've done a decarb on engine (car has over 100,000 kms on it) and it didn't fix the issue. They also thought it could be spark plug or injectors, which it wasn't.
They are now checking mass air flow sensor. My car is also shooting a misfire in cylinder#2 code which I suspect is linked to the rough idle. A few people have mentioned this Mass Air Flow Sensor, so I am hoping that's what it is.

Here is the thread I started in a Mazda 6 forum,
There are vids in this thread, too

 
Last edited:
V
13' CX-5 and 16' Mazda6 both Touring w/Tech/Bose
I am dealing with this on my 2018 Mazda6 Signature (2.5T engine) as well. Dealer is currently troubleshooting and working with Mazda Canada on fixing it. They've done a decarb on engine (car has over 100,000 kms on it) and it didn't fix the issue. They also thought it could be spark plug or injectors, which it wasn't.
They are now checking mass air flow sensor. My car is also shooting a misfire in cylinder#2 code which I suspect is linked to the rough idle. A few people have mentioned this Mass Air Flow Sensor, so I am hoping that's what it is.

Here is the thread I started in a Mazda 6 forum,
There are vids in this thread, too

Wow 100k km on a 2018? You travel a lot.
 

erhayes

Contributor
V
Mazda CX-5 FWD Touring
I believe it is the torque converter unlocking. Every CX5 I've driven has done this at some time. It is rpm related and happens after a FULL warm up when the rpm drops to ~ 600. JMO. Ed
 
V
13' CX-5 and 16' Mazda6 both Touring w/Tech/Bose
OP first thing I would do is reset the electronics = Disconnect Battery. Then test drive. Do a visual inspection focusing on the intake to make sure everything is secure. The airbox is clamped secure.

If you don't have a cheap $20 Bluetooth scanner and $5 Torque Pro app to check for error codes....take it to dealer for diagnostics.

Edit: You're under warranty so take it in and get it documented for potential warranty coverage.
 
Last edited:
Top