Recent content by SpookySpaceKook

  1. S

    Transmission problems w/ 2008

    Well, I followed their instructions and the codes didn't clear. They followed it up with instructions to clean the pins and connector, which also did not fix it. So, it looks like I will need to send it back to them. They will test it to see if/why it failed ($50 charge if it hasn't failed). I...
  2. S

    Transmission problems w/ 2008

    Got a reply: Please follow these steps to resolve your vehicle troubles: 1. Disconnect Battery (30-45 Minutes) 2. Remove Module and clean the plugs and pins thoroughly 3. Clean and inspect the Module harness. Check for loose wires or bad connections 4. Install module and be sure each connecter...
  3. S

    Transmission problems w/ 2008

    Waiting on a reply from them. Since the car passed state inspection after the repair, I figure it is likely that it failed again, but I am working from a place of ignorance.
  4. S

    Transmission problems w/ 2008

    Got it off of eBay, All Computer Resources.
  5. S

    Transmission problems w/ 2008

    Alright, after about 100 miles of smooth driving, the dreaded CEL and A/T came up, the car started bucking, and U0101 came up. Back to square one. I am going to check all the connections and make sure everything is secure. Then, check the connector to the tcm. Anyone know what fuses to check?
  6. S

    Transmission problems w/ 2008

    I bit the bullet and got the TCM repaired, works fine after 60 miles. Thanks for the info!
  7. S

    Transmission problems w/ 2008

    I haven't hooked up a code reader, will it give me codes from before the battery died?
  8. S

    Transmission problems w/ 2008

    Yeah, I am also leaning towards the TCM. The common symptoms I find don't totally match up, however, so I am hoping others have had similar symptoms fixed by a repaired TCM to give me more confidence in the diagnosis. No longer being in limp mode bothers me. I wonder if that is because all...
  9. S

    Transmission problems w/ 2008

    Howdy, I have a problem with my m5 that I can't quite figure out. It comes in two stages: 1. Started the car and put it into reverse. It shifted hard, then when I started driving, seemed like it was stuck in 3rd and the check engine and transaxel lights came on. I parked it and came back when...