Welcome to the James Barone Racing Forum - Upgrade your Mazda with High Quality Parts at Great Prices from JBR!
Upgrade your Mazda with High Quality Parts at Great Prices from JBR!
Results 1 to 9 of 9

Thread: Hesitation, bucking under 3/4 throttle.

  1. #1
    Chedda FlowMSP's Avatar

    03 Mazdaspeed Protege

    Join Date
    Apr 2003
    Location
    Winter Haven, Florida
    Posts
    157

    Hesitation, bucking under 3/4 throttle.

    So I knew i had a bad wastegate, was spiking to 11lbs. Changed it out but still have this other remaining problem. Starting out in 1st gear if i go WOT no issues, but once im in 2nd or 3rd anytime i try to accelerate about 1/2 to 3/4 boost the car bucks and hesitates until i let off. It is building boost fine but the power just isnt transferring. I AM thinking i may have a vacuum leak, boost gauge only shows 4hg at idle. So either the gauge is not working properly or i have a severe vacuum or boost leak somewhere. I made my own boost leak tester, still cant seem to find it. Also changed out any vacuum lines i was able to get to with new ones. I do have a CEL on, downstream o2 sensor, but i think this is due to the non-fouler trick i have not working properly. Any tips? I dont wanna throw random money i dont have at something if its not the problem. Thanks.
    Spicy Orange #1486
    Greddy SP2 Cat-back.
    Hi-Boost FMIC.
    Injen CAI>SRI intake.
    SLS Catless Midpipe.

  2. #2
    Registered Member 2088 MSP's Avatar
    Potential Scammer!

    03.5 silver MSP

    Join Date
    Aug 2010
    Location
    St. Pete FL
    Posts
    599
    is it just like mine did in the following video? (sort of hard to hear but it happens at 6th, 8th & 14th seconds)

    http://youtu.be/S_LWLI1v5ys



    if so, then time for a tune up. Wires plugs and coils. go with the good stuff, NGK wires are a MUST!

  3. #3
    Chedda FlowMSP's Avatar

    03 Mazdaspeed Protege

    Join Date
    Apr 2003
    Location
    Winter Haven, Florida
    Posts
    157
    Doesnt seem quite like that. Its strange that it only happens under 3/4 throttle and not WOT. Bad weather is stopping me from searching for more leaks/problems lol. Ill pull my plugs to check em though. Coils were replaced maybe 6 months ago, same with wires.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #4
    Registered Member xBoostedx's Avatar

    2003 Mazdaspeed Protege

    Join Date
    May 2012
    Location
    Halifax, NS
    Posts
    19
    Mine is sounding exactly like that! It's horrible, it spools an sounds ready but soon as I punch it it just bogs and gives out that horrible sound like In your video. What did you do to fix this problem??

  5. #5
    Registered Member 2088 MSP's Avatar
    Potential Scammer!

    03.5 silver MSP

    Join Date
    Aug 2010
    Location
    St. Pete FL
    Posts
    599
    Quote Originally Posted by xBoostedx View Post
    Mine is sounding exactly like that! It's horrible, it spools an sounds ready but soon as I punch it it just bogs and gives out that horrible sound like In your video. What did you do to fix this problem??
    Spend the money and get GOOD ngk wires! As soon as I did that it was immediately better, still stuttered at very high rpm, so I just bit the bullet and bought good, proper gap copper plugs, and both new coils, and it fixed it.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  6. #6
    Registered Member xBoostedx's Avatar

    2003 Mazdaspeed Protege

    Join Date
    May 2012
    Location
    Halifax, NS
    Posts
    19
    I'm just gonna go big and buy the plugs wires and coils. Could you pm me what you bought man?? Thanks.

  7. #7
    Registered Member Nc MSP's Avatar

    2003 MazdaSPEED Protege

    Join Date
    Nov 2010
    Location
    Charlotte N.C.
    Posts
    224
    mine does it too, i just try to ignore it

  8. #8
    Chedda FlowMSP's Avatar

    03 Mazdaspeed Protege

    Join Date
    Apr 2003
    Location
    Winter Haven, Florida
    Posts
    157
    I ended up getting new plugs and gapped at .032. Much much better now. The former issue is gone. Now onto the other 4,230 problems....yet i still love the car lol.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  9. #9
    Registered Member xBoostedx's Avatar

    2003 Mazdaspeed Protege

    Join Date
    May 2012
    Location
    Halifax, NS
    Posts
    19
    Quote Originally Posted by FlowMSP View Post
    I ended up getting new plugs and gapped at .032. Much much better now. The former issue is gone. Now onto the other 4,230 problems....yet i still love the car lol.
    No matter what happens to this car, and how picky it is. When it runs perfect, its a beast and i wouldnt trade it for anything even on those days where i just want to burn it and call insurance lol.

Similar Threads

  1. Help - hesitation/bucking in higher gears
    By Alladin in forum MS6 ECU, Turbo & Tuning
    Replies: 66
    Last Post: 09-30-2010, 10:07 AM
  2. Part-throttle bucking problems
    By jmv in forum MSP Engine, Performance & Forced Induction
    Replies: 21
    Last Post: 09-13-2008, 12:59 AM
  3. Hesitation/Bucking with DSM AFC
    By Knox Joe in forum MSP Problems & Help
    Replies: 22
    Last Post: 05-25-2007, 07:43 AM
  4. bucking and hesitation!
    By 04speed in forum MSP Engine, Performance & Forced Induction
    Replies: 10
    Last Post: 11-21-2006, 03:18 PM
  5. Hesitation/Bucking
    By Packerfan in forum MSP Archives
    Replies: 5
    Last Post: 11-06-2003, 12:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •