Welcome to the James Barone Racing Forum - Upgrade your Mazda with High Quality Parts at Great Prices from JBR!
Upgrade your Mazda with High Quality Parts at Great Prices from JBR!
Results 1 to 11 of 11

Thread: P0421 Code

  1. #1
    Registered Member

    2002 Mazda Protege5

    Join Date
    Dec 2011
    Location
    New York
    Posts
    55
    Items For Sale

    P0421 Code

    Hi guys I have a '02 protege5 and got a CEL which seems to be code P0421. Car idles, drives fine. Only thing I did do recently is put a chevron fuel injector cleaner in it. I just bought the car used and past inspection. Car has 107k miles. Could it just be the O2 or maybe the fuel cleaner clogged on injector and should go to a jiffy lube place and get the complete fuel system cleaning?

  2. #2
    Registered Member CR3 Motorsports's Avatar
    Authorized Vendor


    Join Date
    Dec 2011
    Location
    USA
    Posts
    1,994
    Items For Sale
    A code P0421 may mean that one or more of the following has happened:

    * The catalytic converter is no longer functioning properly
    * An oxygen sensor is not reading (functioning) properly
    * A sparkplug is fouled up

  3. #3
    Registered Member

    2002 Mazda Protege5

    Join Date
    Dec 2011
    Location
    New York
    Posts
    55
    Items For Sale
    Thanks CR3. I have not changed the plugs yet but I already have NGK's ready to install. Since the car runs and idles smooth with no misfires I didn't bother changing them yet. But just might do that this weekend.

  4. #4
    Registered Member

    2002 Mazda Protege5

    Join Date
    Dec 2011
    Location
    New York
    Posts
    55
    Items For Sale
    Just wondering if anyone would know if the both top cat would be the problem or the top 02 sensor? Rarely the the downstrean one's right?

  5. #5
    Registered Member

    2001 Mazda Protege LX (2.0L)

    Join Date
    Apr 2012
    Location
    Austin, TX USA
    Posts
    1
    *BUMP*

    I have a 2001 Protege LX (2.0L) and I'm throwing the same code, P0421. It appeared right after an oil change/trans flush. Car still idled smooth and power didn't seem inhibited. I was then driving the next day to reset the ecu after removing a battery terminal, and the car suddenly started to bog hard. Almost total loss of power and a terrible rotten egg/sulfur smell for about 5 min. I pulled over and had it checked out. Multiple misfires, and it after testing the ignition coils, they were the culprit. I have changed them and reset the code, and after about 20 more miles, it has come on again.

    Safe to say this is more than likely the cat converter? And if so, does anyone have a resource for changing it yourself?

    Thanks guys!

  6. #6
    Registered Member tweety2300's Avatar

    2001 mazda protege mp3

    Join Date
    Sep 2010
    Location
    virginia
    Posts
    5,728
    Yes it's the precat. Mazda oem is $400. Do you have smog tests? If not look up the non fouler trick

  7. #7
    Registered Member mexicansoljah81's Avatar

    '13 Mazdaspeed3

    Join Date
    May 2005
    Location
    Lacey, WA
    Posts
    308
    Had same issue. For me it was the top catalytic converter. Replaced the whole thing with obx headers and did the non fouler trick to trick the o2 sensor that there was a second cat. The obx headers removes the top cat completely.
    2013 Mazdaspeed3 with Tech Pkg

  8. #8
    Registered Member

    2002 Mazda Protege5

    Join Date
    Dec 2011
    Location
    New York
    Posts
    55
    Items For Sale
    I went the expensive route just to keep the car stock. I started off with just replacing the top(upstream) O2 sensor but within two weeks the same code back on so bought a cat and so far so good.
    I know myself and just sold my 500hp 1993 mustang for personal reasons and I do not want to start the craze of adding power to the car. It will never end for me so I rather leave the car stock just to get around in. LOL

  9. #9
    Registered Member

    Mazda, Protege5, Stock, 2002

    Join Date
    Sep 2012
    Location
    Northern California
    Posts
    27
    Hello all.

    Please help me out! :-(
    I love my car!

    I have a stock 2002 Mazda Protege5. There's no shortage of P0421 threads on this forum but I've yet to find someone who has actually FIXED the issue once and for all.

    I've had a P0421 + CEL for at LEAST 3-4 years. Yep, years...but the gas mileage and general performance of the car has remained stable for all this time, despite the CEL and the P0421. Ultimately, it was a horrible idea not to tend to it right away-- but I didn't expect to keep the car this long.

    Thing being, I now have to get it smogged, the CEL is getting in the way of doing so. I have a gut feeling that it would pass but you can't smog with a CEL.

    Aside from some pinging at 2000RPMs and a bit of struggle on VERY steep hills (pedal all the way down and car has difficulties going up, especially if it's also hot out), the car runs great and idles quite nicely (even from a cold start). It has 255K miles on it and runs very well considering. (Sidebar: I'd love to resolve the pinging noise; tried higher octane already. No additives yet and probably won't go there.)

    I just ordered the OEM precat and before I install it, I want to be sure that I've covered all my bases and won't ruin the new precat. I've also heard horror stories about people replacing the precat, O2 sensors, EGRs, etc.--and the CEL and P0421 issues persist. I simply can't afford to have that happen...not financially or otherwise.

    Here's what I've completed thus far:
    - Spark Plugs / 9-Jun-2012
    - Wires / 9-Jun-2012
    - Fuel System Cleaning (mechanic cleaned all lines, no additives) / 9-Jun-2012
    - Coils (2) / 17-Sep-2012
    - O2 Sensor, Downstream only / 19-Sep-2012
    - PCV Valve / 22-Sep-2012
    - Battery Checked, 12.9V = OKAY / 22-Sep-2012
    - MAF cleaning (only) / 24-Sep-2012

    I've reset/deleted the codes every time I've done a job and the CEL comes back on after some amount of driving (all monitors cleared). Here's a curveball, after resetting, I do get P0300 and P0660 as well but they eventually subside (intermittent, I suppose?). I haven't checked for these codes recently and they MAY have been resolved by the new coils.

    I wanted to check and clean the EGR but it's way beyond my abilities. I'm not trained and most of what I've done thus far has been very easy and I've relied on the suggestions of others and knowledge I've gained from this forum.

    I paid a pretty penny for the precat and I'm happy to make the investment on other parts, too-- especially if that means I can get more life out of the car and pass CA smog.

    What else would compromise the (new) precat? If the EGR was "bad", wouldn't I be getting EGR specific codes?

    Has anyone fully resolved this code/associated issues? Again, passing smog is my immediate goal but if I can prolong the life of this great car by doing some other repairs, I'll do it...

    Thanks everyone.
    NM
    Last edited by Sailingsenses; 09-25-2012 at 03:24 PM.

  10. #10
    Registered Member tweety2300's Avatar

    2001 mazda protege mp3

    Join Date
    Sep 2010
    Location
    virginia
    Posts
    5,728
    P0660 is for Vic's solnoid it isn't emission related and won't throw a cel

    You don't have to replace the precat, you can use a non fouler to trick the ecu and the cel will go off, it's worked for me for 2 years. People have deleted the precat and had just the main cat and passed emissions but idk if they were in cali or not though

  11. #11
    Registered Member

    protege 5 2002 sliver 5 spd manual

    Join Date
    Nov 2012
    Location
    richmond hill
    Posts
    5
    i had that code as well i changed the manifold cat on it and both up and downstream o2 sensors and no more code and my car just passed emission, now the manifold cat aint cheap i spent 350+ tax and my o2's were 265 for both so its gonna cost you but in the end it helps

Similar Threads

  1. code p0421
    By mexicansoljah81 in forum Protege5 Lounge & Welcome Area
    Replies: 6
    Last Post: 06-18-2010, 10:35 AM
  2. P0421 code on p5 help...
    By flyfishnc in forum Protege Performance
    Replies: 3
    Last Post: 05-22-2010, 05:25 PM
  3. P0421 Code
    By themodefanatic in forum Protege5 Lounge & Welcome Area
    Replies: 8
    Last Post: 08-06-2009, 12:26 PM
  4. p0421 code among others
    By brett02 in forum Protege5 Lounge & Welcome Area
    Replies: 2
    Last Post: 01-04-2008, 11:14 PM
  5. Cel Code P0421
    By BlkMica_03 in forum Protege5 Lounge & Welcome Area
    Replies: 30
    Last Post: 04-19-2007, 05:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •