CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Page 1 of 3 123 LastLast
Results 1 to 15 of 32

Thread: Stumble, misfire, no power under load issue.

  1. #1
    Registered Member StealthWyvern's Avatar

    03.5 YLW MSP

    Join Date
    Mar 2006
    Location
    Jaxs
    Posts
    9,988

    Stumble, misfire, no power under load issue.

    Here recently my car has been feeling extra sluggish more so then normal. Well as of lately it started what felt like a misfire every now and then only under load. The car currently has no power what so ever.. literally like no power under load I cant speed up hardly to get around someone now.

    I've replaced, plugs, wires, and coil pack yet the issues still occurs. The car idles fine and I can rev it no problem. However I cant accelerate worth a fuck due to this misfire/stumble/no power issue. Even if I roll onto the throttle you can feel the car bog down right before its going to stumble and misfire. It does not do it to the point that it throws a CEL which is the weird part.

    Now I can cruise down the road without issue its just trying to accelerate that I have an issue with. I was told to remove the vac line adn plug it off the FPR and see if that made any difference and it did not. Also the car still sounds the same while running with the MAF disconnected and still revs fine.

    I'm currently trying to get a hold of one of the local MSPer's to see if I can switch MAFs for a few min just to see if that is my issue or not. I also hear that it could also be the TPS and or the IAC. However I have no ways of testing those and no CELs on the car currently.

    Edit:
    Another thing to note is that it really seems to be a load issue. Every time the car gets around -5 of the boost gauge it bogs and acts up.


    Edit #2:

    Engine Mods:
    Perrin FMIC, Turbo X's BPV, Greddy SP2 catback, Perrin SRI, Stock tune and stock 6psi boost.
    Last edited by StealthWyvern; 07-10-2010 at 02:24 PM.

  2. #2
    ASE Certified Technician

    2002 Mazda Protege ES

    Join Date
    Jul 2004
    Location
    Staten Island, NY
    Posts
    1,203
    Do you have a wideband a/f guage?
    Black Mica 02 Protege ES-T aka TurboMatic

    Current Mods:
    shaved side moldings-powdercoated black valve cover-mazda front lip-20% tint-slp hood
    Dual two 12" subwoofers- power akoustic amp
    Garret gt25r turbo 6psi-steedspeed exhaust mani-corksport s&j pipe-MAM midpipe w/ highflow cat-Racing Beat catback exhaust-kartboy exhaust hangers-
    turbohoses smic,sri and intercooler pipings- forge bpv-hks ssqv- begi rrfpr-flyin miata o2 clamp- sls side and front motor mounts-lentech street terminator valvebody-B&M trans cooler
    autometer a/f wideband, boost-trans and oil temp, oil pressure-
    brembo cross drilled/slotted rotors-axxis metal master pads-motegi mr7 rims(chrome)-pirelli p zero nero m+s 205/45/16-tokico hp-goldline springs

  3. #3
    ASE Certified Technician

    2002 Mazda Protege ES

    Join Date
    Jul 2004
    Location
    Staten Island, NY
    Posts
    1,203
    Or a scan tool to monitor the oem o2 sensor voltages? Either the car is running very lean or very rich.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #4
    Registered Member StealthWyvern's Avatar

    03.5 YLW MSP

    Join Date
    Mar 2006
    Location
    Jaxs
    Posts
    9,988
    Quote Originally Posted by SIBalla23 View Post
    Do you have a wideband a/f guage?
    not really... well i do but its not installed(need a bung and a mount for it) plus i need to find it lol.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  5. #5
    ASE Certified Technician

    2002 Mazda Protege ES

    Join Date
    Jul 2004
    Location
    Staten Island, NY
    Posts
    1,203
    Also please note any mods done to car as some of us may not be familiar with your setup
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  6. #6
    Registered Member StealthWyvern's Avatar

    03.5 YLW MSP

    Join Date
    Mar 2006
    Location
    Jaxs
    Posts
    9,988
    Quote Originally Posted by SIBalla23 View Post
    Also please note any mods done to car as some of us may not be familiar with your setup
    inserted that info in the first post and taken right from my car domain link in my sig. Also note the car pulls -21 at idle so no vac leak.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  7. #7
    ASE Certified Technician

    2002 Mazda Protege ES

    Join Date
    Jul 2004
    Location
    Staten Island, NY
    Posts
    1,203
    How are you controlling fuel?, Fpr and what else? O2 clamp or msp ecu
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  8. #8
    Registered Member StealthWyvern's Avatar

    03.5 YLW MSP

    Join Date
    Mar 2006
    Location
    Jaxs
    Posts
    9,988
    Quote Originally Posted by SIBalla23 View Post
    How are you controlling fuel?, Fpr and what else? O2 clamp or msp ecu
    you must of over looked it but Stock tune and stock boost.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  9. #9
    ASE Certified Technician

    2002 Mazda Protege ES

    Join Date
    Jul 2004
    Location
    Staten Island, NY
    Posts
    1,203
    Yes i did, sorry. When i read fpr, I was thinking an aftermarket fpr. Anyways can you get your hands on a scanner that has live data? You are using premium fuel correct?
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  10. #10
    ASE Certified Technician

    2002 Mazda Protege ES

    Join Date
    Jul 2004
    Location
    Staten Island, NY
    Posts
    1,203
    These are all possible causes from the service manual:
    Improper A/C system operation
    Erratic signal or no signal from CMP sensor
    Air leakage from intake-air system parts
    VICS malfunction
    Tumble swirl control system malfunction
    Purge control solenoid malfunction
    EGR valve malfunction
    Brake dragging
    Erratic signal from CKP sensor
    Low engine compression
    Vacuum leakage
    Poor fuel quality
    Spark leakage from high-tension leads
    Air cleaner restriction
    PCV valve malfunction
    Improper valve timing due to jumping out of timing belt
    Restriction in exhaust system
    Intermittent open or short in fuel pump circuit
    Inadequate fuel pressure
    Fuel pump mechanical malfunction
    Fuel leakage from fuel injector
    Fuel injector clogging
    Intermittent open or short of MAF sensor, TP sensor and VSS
    ATX malfunction
    Clutch slippage
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  11. #11
    ASE Certified Technician

    2002 Mazda Protege ES

    Join Date
    Jul 2004
    Location
    Staten Island, NY
    Posts
    1,203
    How did the plugs look when you replaced them?
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  12. #12
    Jack of all asses Wagonbacker9's Avatar

    2004 'Hoe

    Join Date
    Apr 2008
    Location
    Menomonee Falls, WI
    Posts
    26,748
    Quote Originally Posted by StealthWyvern View Post
    Also the car still sounds the same while running with the MAF disconnected and still revs fine.
    WTF? I tried starting mine without it once (not intentional), it died instantly, and threw a CEL.

    2003.5 MSP Titanium Grey #1421 - SOLD
    1994 Chevy Blazer 6.5TD - Traded
    2006 GTO Quicksilver Metallic LS2/M6 - 426hp/416tq - SOLD
    1993 Chevy K2500 - SOLD
    2004 Chevy Tahoe - Kid hauler
    1999 Chevy Camaro - Traded
    2001 Lincoln LS - WHAT A PIECE OF $#!& - SOLD

  13. #13
    #1566

    Titanium MSP

    Join Date
    Apr 2005
    Location
    About an hour North of Philly
    Posts
    439
    You test your wastegate?
    #1566

  14. #14
    Jack of all asses Wagonbacker9's Avatar

    2004 'Hoe

    Join Date
    Apr 2008
    Location
    Menomonee Falls, WI
    Posts
    26,748
    Quote Originally Posted by IggyPop View Post
    You test your wastegate?
    problem is kicking in before boost, so thats not it. plus, fuel cut doesn't feel anything like "bogging" or "stumbling" its like a ghost stepped on your brakes for you.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  15. #15
    MSP# 518 SeR_Cyclops's Avatar

    Mazdaspeed Protege

    Join Date
    Sep 2006
    Location
    Somerset, Kentucky, United States
    Posts
    5,489
    Id check your WGA and fuel pressure. We have a spare bung in our J pipes you can put that wideband in....

Page 1 of 3 123 LastLast

Similar Threads

  1. Power Issue/question
    By iJay in forum Protege5 Lounge & Welcome Area
    Replies: 2
    Last Post: 04-16-2010, 04:23 PM
  2. power locks issue
    By HondaNoMore in forum MSP Problems & Help
    Replies: 4
    Last Post: 01-21-2008, 01:59 PM
  3. 93 Protege.. Cold Misfire/Engine stumble at 2000-2500rpm..
    By pawel_r in forum Protege Lounge & Welcome Area
    Replies: 2
    Last Post: 04-22-2005, 01:13 AM
  4. Info for Hesitation/Stumble issue
    By boostisgood in forum MSP Archives
    Replies: 70
    Last Post: 10-28-2004, 03:53 PM
  5. Re Hesitation/stumble issue
    By bitsmaker in forum MSP Archives
    Replies: 1
    Last Post: 07-04-2003, 03:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •