Visit TeamMFactory.com for the best Mazda transmission components!
Visit TeamMFactory.com for the best Mazda transmission components!
Results 1 to 4 of 4

Thread: BTN Fuse Blowing

  1. #1
    Registered Member duffbuster243's Avatar


    Join Date
    May 2007
    Location
    Scranton, PA
    Posts
    306

    BTN Fuse Blowing

    I have a slight problem with my MSP. I started the car today and it was fine but the radio wasn't working. I shut it off figuring if I turn it back on the radio might work. After shutting it off I tried to start it back up and there was nothing, the starter wasn't getting any power. I managed to get it started by rolling it and popping the clutch and it ran fine. I checked the fuses and all were good except the BTN fuse under the hood. It is a 40a fuse. I tried a new one only to have it instantly blow again. Right now the radio doesnt work and the alarm doesnt work. I know there has to be a short somewhere. I would like to know if anyone has had a similar problem or if anyone knows exactly what electronics are connected to this fuse so that I can remove them one by one to find my short?
    Lazer Blue MSP #2500 Sold
    2002 Sunlight Silver Protege5 Auto Sold
    1990 White Turbocharged Miata
    2006 Titanium Mazda3s
    2003 Blazing Yellow MSP #249

  2. #2
    cheif smacktalker yudkib's Avatar


    Join Date
    Mar 2009
    Location
    hartford ct
    Posts
    4,605
    im guessing you have to pull the car apart. that sucks, because with a blown fuse you cant even use a multimeter to make things a little easier.

    maybe you could take it to a pro and get a quote, id imagine they want like 120 to fix that, but it might be worth it.
    titanium #129 - sold.
    "What do I think of success? It sucks, too much press, I'm stressed - Too much stares, two breasts, too upset. It's just too much mess. I guess I musta blew up quick, grew up quick, was raised right. Whatever you say is wrong, whatever I say is right"

  3. #3
    Registered Member duffbuster243's Avatar


    Join Date
    May 2007
    Location
    Scranton, PA
    Posts
    306
    I found the problem, the rear window defroster must be bad and is blowing the fuse. Just figured I would post in case anyone else ever runs into the problem in the future.
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

  4. #4
    cheif smacktalker yudkib's Avatar


    Join Date
    Mar 2009
    Location
    hartford ct
    Posts
    4,605
    wow, howd you figure that out?
    Sigs are visible only in your first post on a page. To change your thread display preferences, click here and enable 'Always Show Signature'.

Similar Threads

  1. HID kit blowing my fog fuse....
    By LReyes66 in forum Mazda3 Audio & Electronics
    Replies: 11
    Last Post: 07-16-2008, 10:53 AM
  2. fuse f69 keeps blowing
    By riccitelli in forum MS3 ECU & Tuning
    Replies: 9
    Last Post: 04-24-2008, 11:03 PM
  3. fuse keeps blowing
    By Andrewsmc in forum MSP Audio & Electronics
    Replies: 8
    Last Post: 07-18-2007, 10:14 PM
  4. Help! Blowing Fi Fuse
    By CBIGGS in forum Protege5 Lounge & Welcome Area
    Replies: 7
    Last Post: 10-12-2006, 10:09 AM
  5. Fuse blowing
    By Fade in forum Protege5 Lounge & Welcome Area
    Replies: 0
    Last Post: 06-30-2005, 01:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •