CorkSport.com is MAZDA PERFORMANCE!
CorkSport.com is MAZDA PERFORMANCE!
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: 2002 Mazda Protege 5 - P0421 & P0300 OBDII CODES

  1. #1
    Registered Member


    Join Date
    Oct 2008
    Posts
    24

    2002 Mazda Protege 5 - P0421 & P0300 OBDII CODES

    HELP! I posted once before and have done everything I can think of nobody can seem to help me with problem. Trouble codes 1) P0421 - Warm up catalyst below threshold(bank 1) 2) P0300 - random/multiple cylinder misfire detected. Only happens at 70MPH. Replaced all vacuum lines . Replaced EGR Valve. Replaced plugs/wires. All new. Replaced fuel injectors (ALL 4). Had intake manifold cleaned out. Replaced Pre-cat(the one that bolts directly to the exhaust manifold. Replaced BOTH O2 sensors. Had exhaust system checked for leaks. Have taken it to multiple mechanics. No mechanic can find any other problems. Have spent endless amount of money to try and fix problem. Ready to blow the damn thing up. HHHHEEEELLLLPPPP!!!!!! I'm frigin losing my mind. After i replaced the pre-cat it ran fine for about 3 days then started to act up again. At 70MPH it kicks down no power with a few kicks of the gas pedal it kicks back in. As long as I keep it over 70MPH or under 65MPH its fine. Any help would be appreciated..

  2. #2
    Registered Member HazardLevel5's Avatar

    '02 Mazda Protege5

    Join Date
    Jan 2009
    Location
    Tennessee
    Posts
    17
    It seems like you've tried a lot, however, I noticed you didn't mention anything about coil packs... My car had those codes and the problem ended up being solved with new coil packs.

  3. #3
    Registered Member


    Join Date
    Oct 2008
    Posts
    24
    yeah. no mechanic mentioned that. just replaced and seems to be running alot better.

  4. #4
    MP5'er patsissons's Avatar

    2003 P5

    Join Date
    Apr 2007
    Location
    St. Albert
    Posts
    40
    themodefanatic: i am in the same boat as you, except it doesn't happen on the 70MPH line, but rather pretty much at any speed. But i get P0300's intermittently (usually about once a week) and P0421's about once a day. Did you ever solve your problem, or at least narrow it down? I am thinking about selling this car as it is getting that annoying (though i would likely buy another mp5).
    Pat

    "The goggles... they do nothing"

  5. #5
    Registered Member

    mazda protege 5

    Join Date
    Sep 2010
    Posts
    1
    My 2003 P5 has p0421 and p0300 codes. I know what they mean but am unable to fix the problem. I have replaced EGR valve, 2 O2 sensors, cat 3x, both egnition coils, spark plugs with complete tune up and timing belt change. spent a lot of $$$. Anyone have same problem and able to fix? I have 111k on my car. At first engine light goes on solid and I have less power.Sometimes it lags for a sec and returns power. right before cat goes, It loses power for minutes anywhere, anytime and then it is hard to regains any power. some times I will get down to 20mph and unable to gain speed. The light flashes at this time.

  6. #6
    Registered Member Tzar177's Avatar
    Donated: $15


    Join Date
    Jul 2005
    Location
    Northern Kentucky
    Posts
    2,804
    If you CEL is flashing, you should not be driving it. Where are you located? Maybe someone local to you can help
    Fuelly

  7. #7
    Registered Member MAKRAA's Avatar

    2002 Mazda Protege 5

    Join Date
    Mar 2011
    Location
    Canada
    Posts
    12

    Has anyone fixed this problem yet?

    I have hadthese two codes on my 2002 mp5 since oct 2009
    I have replaced the spark plugs, wires, 02 sensors x2, the ERG kit, catylictic converter, coil packs have been tested, ran many bottles of fuel injecotor cleaner though it. It has been into multiple mazda and private shops plus I have worked on it myself. my problem used to be every couple weeks to months always at about 60 km/h it would lose power almost stall, the engine light would flash for a couple seconds it would suck a bit of gas, then it would go solid and run fine and the engine light would clear itself. Now almost a year and a half later and alot of money and work later it has hugely deteriorated, The engine light is always on solid, it has fits of no power and flashing that can last several minutes, it throws the codes at any speed even in idle it runs terribly and I only get about 300-400 km a tank. I hate the car, I still owe on the car, I am a student with no money to fix or replace the car anymore but am looking at getting a loan to do so but am starting to feel that replacing the vehicle is my only option...

  8. #8
    Registered Member


    Join Date
    Jan 2008
    Location
    Nashville,Tn
    Posts
    100
    have you or anyone else checked the fuel pump or the strainer around it?

  9. #9
    Registered Member


    Join Date
    Jul 2007
    Posts
    62
    im going through same issue now73000 miles on a 03 protege 5. i have same codes. mechanic said wrong size spark plugs,he said if issue persist ima need to change cat o the car. is it true this car has two of them. another mechanic said it could be coils. so after reading all the previous post im glad to see im not the only one
    IMG]http://img160.imageshack.us/img160/9679/cimg2544ok4.jpg[/IMG]




  10. #10
    Registered Member MAKRAA's Avatar

    2002 Mazda Protege 5

    Join Date
    Mar 2011
    Location
    Canada
    Posts
    12
    I keep getting told it is not a problem with the fuel pump, fuel filter or fuel injectors by two shops (one mazda one not) but they have not been replaced and i do not know what has been done to test or check them... But they are the only things left to replace.. I am due to talk to a third shop for another opinion...

    And yes there are two cats in mine, And i hate to be negative but i regret putting a dime into this car, I know a lot of people who love there Mazda's but I am no longer one of them, I have been chasing this engine light every time I have the money to put into it and regret it time and time again. If anyone else were too be just finding these problems with their similar car and getting told it could be a couple of these things I would seriously consider how much you like this car before you put anymore money into it.. And I did love it..
    Last edited by MAKRAA; 03-11-2011 at 08:30 PM.

  11. #11
    Registered Member


    Join Date
    Jan 2008
    Location
    Nashville,Tn
    Posts
    100
    re-read your original post and realized you said coil packs had been tested, not replaced. Those things have a life span of about 60000 miles. You can get a good price at rockauto or any auto parts store. The coils can test fine and still mis-fire randomly. For parts and labor your looking at ~ $180 US. Much less if you can do it yourself. It's fairly straight forward. 4 bolts on top of the valve cover, just be careful getting the old ones off, the boots can tear and get stuck.

    If you are still getting the p0421 code after you have replaced the pre-cat (warm up catalyst) , you have mis-fired enough to ruin the new one, depending on your local emission laws, may or may not be a problem, but it's about $800-1000 US to replace so keep that in mind before spending any more money. Best of luck, sorry for your troubles.

  12. #12
    Registered Member MAKRAA's Avatar

    2002 Mazda Protege 5

    Join Date
    Mar 2011
    Location
    Canada
    Posts
    12
    Cool I can try replacing the coil packs then, just thought if they tested good, they were good.

    Got the p0421 the first time I got the p0300 light, after the converter was replaced... So what's that mean?

  13. #13
    Registered Member

    2002 Protege5

    Join Date
    Mar 2011
    Location
    Seattle, WA
    Posts
    7
    Quote Originally Posted by MAKRAA View Post
    Cool I can try replacing the coil packs then, just thought if they tested good, they were good.

    Got the p0421 the first time I got the p0300 light, after the converter was replaced... So what's that mean?
    Please read my last post: http://www.mazdas247.com/forum/showt...79#post5607479

    Now we have the P0421 code also. It is a pending code that only occasionally lights the CEL. P0300 will be followed by P0421. The fact is that extended occurrence of misfire ruins the upstream cat. The FIRST time your car stumbled or threw on the CEL, you SHOULD HAVE stopped driving the damn thing. These cars are so crappy that they can't handle a minor malfunction, it's like a chain reaction. 1 thing leads to another.

    Please read what I wrote about coil packs. I have a set of defective coil packs in my garage. They WILL test fine. The test does not cover heat absorbed dielectric strentgh. The test only checks coil resistance. Who gives a crap about coil resistance? What kills these coils is heat. When they get hot, the high voltage spark finds other paths to ground, causing random misfire. If you take the car to a shop, their multimeter won't test the resistance to high voltage. They just check static coil resistance. Only a dead open coil or shorted coil would fail a resistance check.

    These cars are garbage as far as a Japanese branded car goes. Must be Ford's influence, as my co-workers Lincoln LS has the same problems.

    And if you are still getting P0421, did you clear the previous code?
    Is the new cat of decent quality?
    Did a P0300 occur anytime after the cat was replaced? If it did, your cat is likely damaged again. If you search P0300 and P0421 codes, you'll find some people have replaced their cats several times without ever replacing their coils. A cat costs at least $270, so that's expensive multiple times! Remember, bad coils will allow raw fuel into the cat. The fuel will burn inside the cat which damages it. Bad MAF? nope, won't destroy the cat. Neither will a bad EGR. If you've had a P0300 recently, change the coils. Both of them. Then go get your cat replaced under warranty and don't tell them what happened otherwise it will be a recurring bill for you.

    Yes these cars suck. Wait until you find rust in the doors and wheel wells. Icing on the cake..........

  14. #14
    Registered Member MAKRAA's Avatar

    2002 Mazda Protege 5

    Join Date
    Mar 2011
    Location
    Canada
    Posts
    12
    I wish I could have stopped driving it but not exactly an option for me so, sucks to be me I made the car suck more than it already did.

    I clear the codes almost daily this problem has been going on for 1.5 years for me... I put money into it when I can I am a student, will be working soon, basically deciding whether to fix/get rid of the car for a beater, to get me through the next year while I pay off debt.

    The cat is not a Mazda cat does that qualify as decent quality? But honestly, no it's a direct fix converter that cost $750 CAN for it and installation as opposed to the $1300 for just the cat at the Mazda, if I have to replace the cat again, I will probably not be keeping this car... I can try the coils, but the car is not under warranty.

  15. #15
    Registered Member MAKRAA's Avatar

    2002 Mazda Protege 5

    Join Date
    Mar 2011
    Location
    Canada
    Posts
    12
    PS thanks for the coil pack education..

    The coil packs aren't the little coils in the boots that go between the wires and the spark plugs are they?
    Last edited by MAKRAA; 03-12-2011 at 02:23 PM.

Page 1 of 2 12 LastLast

Similar Threads

  1. Error codes p0300 and p0421 Please help
    By 02 Protege ES in forum Protege Performance
    Replies: 18
    Last Post: 06-30-2014, 06:46 PM
  2. Flashing CEL - P0300 & P0421 - 2001 2.0 ES
    By adrocking in forum Protege Performance
    Replies: 13
    Last Post: 03-12-2011, 01:17 PM
  3. OBDII Codes
    By RallyeRedSi in forum Protege Performance
    Replies: 26
    Last Post: 10-21-2009, 02:50 AM
  4. p0171 p0300 Codes
    By Laramie in forum MSP Problems & Help
    Replies: 4
    Last Post: 02-03-2009, 10:45 AM
  5. CODES P0421 and P0171
    By msp_rad in forum MSP Problems & Help
    Replies: 15
    Last Post: 01-10-2008, 05:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •